Get in touch
Back
Resolved

Server is under DDOS attack

Started 23 Aug at 07:18pm GMT+8.

WebHero Dedicated Server Email Receiving Service Email Sending Service
Created

A larger-scale DDOS attack has been detected and is currently bringing down our servers.
Our engineers are working to alleviate the issue.

Update: We have detected a brief period of inaccessibility and are currently back online.

Posted 23 Aug at 07:18pm GMT+8.