Get in touch
Back
Resolved

Internet connection issue

Started 5 Oct at 10:06pm GMT+8.

WebHero Dedicated Server Email Receiving Service Email Sending Service
Created

Both of our networks (including the backup internet) are currently unavailable. One of the power sources appears to be malfunctioning. We are still awaiting more information from Datacenter.

Posted 5 Oct at 10:06pm GMT+8.