Get in touch
Back
Resolved

503 errors issue

Started 18 Dec at 09:55pm GMT+8.

WebHero Cloud
Created

We're currently receiving reports of some websites experiencing 503 errors.

Our server engineers are investigating the issue now. Apologies for any inconvenience caused.

Posted 18 Dec at 09:55pm GMT+8.