Back
Maintenance
Maintenance
Schedule webmail software update
Completed 3 Mar at 07:00am GMT+8.
Cloud Email Receiving Service
Cloud Email Sending Service
Completed
Maintenance completed
Posted
3 Mar at 07:00am GMT+8.
Started
Software upgrades will be carried out on the webmail platform by administrators during this period. While mail client connections via IMAP/POP3/SMTP will continue to function normally, there may be interruptions in accessing the webmail interface.
Posted
3 Mar at 05:00am GMT+8.