Back
Maintenance
Maintenance
Scheduled Server Software Update
Completed 22 Aug at 03:10pm GMT+8.
WebHero Dedicated Server
Email Receiving Service
Email Sending Service
Completed
Maintenance completed
Posted
22 Aug at 03:10pm GMT+8.
Started
We'll be performing a server upgrade to improve software functionality and stability. During this time, you'll experience a short 3 to 5 minutes of downtime.
As always, our customer service team is available for any questions or concerns. Thank you for your understanding,
Posted
22 Aug at 03:00pm GMT+8.