Get in touch
Back
Resolved

Server is suffering from degraded performance and intermittent downtime

Started 26 Sep at 12:05pm GMT+8.

WebHero Dedicated Server Email Receiving Service Email Sending Service
Created

Our server is suffering from a short downtime and degraded performance. Our team has started working on restoring the service. The incident is caused by a network issue. We have submitted a request to inform upstream and ISP providers to resolve the issue.

Posted 26 Sep at 12:05pm GMT+8.