Get in touch
Back
Maintenance

Scheduled Server Software Update

Completed 4 Feb at 10:15pm GMT+8.

WebHero Dedicated Server Email Receiving Service Email Sending Service
Completed

Maintenance completed

Posted 4 Feb at 10:15pm GMT+8.
Started

We'll be performing a server upgrade to improve software functionality and stability. During this time, you'll experience a short 3 to 5 minutes of downtime.
As always, our customer service team is available for any questions or concerns. Thank you for your understanding.

Posted 4 Feb at 10:00pm GMT+8.