Back
Maintenance
Maintenance
Upgrade to CloudLinux
Completed 1 Apr at 11:45pm GMT+8.
WebHero Dedicated Server
Email Receiving Service
Email Sending Service
Completed
Maintenance completed
Posted
1 Apr at 11:45pm GMT+8.
Started
We are pleased to announce that we will be upgrading our Linux server to the most recent Cloudlinux operating system
During this upgrade, our server is expected to be unavailable for 45 minutes.
Thank you for your patience, and please accept our apologies for any inconvenience.
Posted
1 Apr at 11:00pm GMT+8.